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Agenda

 What are Power Query & M Language?
* Connect to Data Files
e Data Manipulation | — Built in Functionalities

* Data Manipulation Il — Self-defined
Calculations

Case Study used in this ASM Talk: Claim experience study on medical products,
i.e. loss ratio & incidence rate.
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What is Power Query?

AutoSave (@ off) ® - 07 =  Bookl - Excel 02 Connecting to and transforming data in Excel
File Home Insert Draw Page Layout Formulas Data Review
fﬂ [E| From Text/CSV [('?) Recent Sources |r>“ [H Queries & Connections @ Transform @ Combine @ Share
e [5 From Web [’é Existing Connections or RJI; D =
e res
- E& From Table/Range . | " I - P
Data Al B /4' B -3 4
Get & Transform Data Queries & Connections
“Get & Transform Data” section under Excel’s Data tab Image Source: https://support.office.com/en-us/article/power-
query-overview-and-learning-ed614c¢81-4b00-4291-bd3a-
55d80767f81d

. Microsoft Power Query is a business intelligence tool available in Excel that allow users to connect
data from various sources and clean, transform and reshape data in order to meet our data analysis
needs.

. Power Query is available as add-ins for Excel 2010 & 2013 (need to download and install). Starting
from Excel 2016, it was renamed to “Get & Transform” and appears in the Data Tab — no longer need
to perform additional installation.

. How does Power Query works?

—  Connect - Connect to data files, as Tables.
—  Transform — Shape the Tables in accordance to your needs, without altering the original source data.

—  Combine — Create consolidated tables from multiple data sources, which is commonly known as “table joining”.
Furthermore, you can insert new columns to additional calculations.

—  Share — Save your queries and load the results to Excel as Tables. If your queries are setup to allow for “reuse”,
just change the run parameters and refresh the tables available in the worksheets.
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What is Query Editor?

B - s Policy Data - Power Query Editor O X
Home Transform Add Column View ~ o
ﬁé A :fq Properties 1 B 8l r""‘_| % Data Type: Whale Number ~ % [& New Source *
= L EI%T Advanced Editor il @ Use First Row as Headers ~ [E) Recent Sources ¥
Close &  Refresh = Manage Reduce Split  Group Combine  Manage Data source
Load~  Preview ™ Rlanage Columns = Rows ™ Column~ By 22 BeplacelValues - Parameters = settings
Close Query Sort Transform Parameters  Data Sources New Query
x = Table.AddColumn(#"Added Exposure”, "Earned Premium", each ;
> | k|| ¢ posure”, ’ v Query Settings X
7=, [123 Policy Number El £ Entry Date ﬂ li5] Termination Date ﬂ 123 Plan
- 4 PROPERTIES
2 1 10000001 02/01/2018 02/01/2019
T A Name
S. 2 10000002 03/01/2018 03/01/2019 .
| Policy Data
3 10000003 04/01/2018 04/01/2019
4 10000004 05/01/2018 05/01/2019 g it
5 10000005 06/01/2018 06/01/2019 4 APPLIED STEPS
6 10000006 07/01/2018 07/01/2019
Start_Date
7 10000007 08/01/2018 08/01/2019 N
End_Date

. To transform & combine data files, we need to amend or create new queries using Query Editor.
Under Applied Steps section, we can see the step-by-step data manipulation done on a query —
which some of the steps are automatically created by Power Query!

. There are two ways to transform & combine data files:

—  Use build-in functions under Home, Transform & Add Column tabs. Power Query will enter relevant codes in the
query (similar to how Record Macro works in Excel VBA —we may not remember how to write VBA codes for
paste value, right?)

—  Use Advanced Editor under View tab to manually required codes.
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What is M Language?

Advanced Editor O X
Polic Y Data Dispiay Oplions 7} @
let | |

Start_Date = DateTime.Date(Getvalue("StartDate")),

End_Date = DateTime.Date(GetValue("EndDate")),

Tot_Exposure=365,

Source = Excel.Workbook(File.Contents("D:\Training\20200423 ASM Talk\Sample Data.xlsx"), null, true),
#"Policy Data_Sheet” = Source{[Item="Policy Data",Kind="Sheet"]}[Data],

#"Promoted Headers” = Table.PromoteHeaders(#"Policy Data_Sheet”, [PromoteAllScalars=true]),
#"Changed Type" = Table.TransformColumnTypes(#"Promoted Headers",{{"Policy Number", Int64.Type}, {"Entry
#"Added Exposure"” = Table.AddColumn(#"Changed Type", "Exposure", each DateDiff([Entry Date],[Termination
#"Added Earned Premium" = Table.AddColumn(#"Added Exposure™, "Earned Premium", each Number.Round([Exposur

in
#"Added Earned Premium”

+/ No syntax errors have been detected.

. You can find out codes used by a query from the formula bar or Advanced Editor. Normally, it is
insufficient for actuarial users to solely rely on the built-in functions in the Power Query.

. Programming language used in Power Query is normally known as “M Language”. It is important to
take note of the following characteristics:

— Need toincluded “let...in...” pairing in a query that involves tables.
—  Codes, variables & built-in functions are case-sensitive.

—  Each line of codes (except the last line of codes before “in”) need to be ended by a “,” before entering a new
line.
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How to Connect to Data?

Calculationxlsx ~

Draw Page Layout Formulas Data Review
I:(hB Recent Sources D’ E Queries 8 Connections
[‘f\j Existing Connections =/

Refresh D
All ~

ies & Connections
> I:Bﬁ From Workbook

I:% From Database > I:% From Workbook
Import data from a Microsoft Excel
™ workbook.
== From Azure > Prunn o 1 c r
Import Data ? X
Select how you want to view this data in your workbook.
D O Table

O PivotTable Report

Where do you want to put the data?

Existing worksheet:

ES

New worksheet

D Add this data to the Data Model

| Properties... " |

OK | ‘ Cancel |
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To connect to a standalone data file, go to Data tab > Under
Get & Transform Data section, click Get Data > Click From
File > Select the option as per your data file type > select
your data file & click Open.

If you connect to an Excel file, you need to select the
worksheet which store the required data. Select “Load To”
(the drop-down button at the bottom of the dialog box) to
display Import Data dialog.

Normally, we only connect to the required data files instead
of loading the entire data set to a worksheet (which occupy
a lot of computer resources). Select Only Create Connection
> Click OK.

Suggestions for Microsoft Access users:

If you are an Access user, you will find Power Query has
similarities to Access. As an Access file has a 2GB file size
limit, it is always recommended to always connect to data
files instead of import the entire data set into Access
database — furthermore, Access database requires users to
do compact & clean up manually.
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How Connected Data Look Like?

> | fx || = Table.AddColumn(#"Added Exposure”, "Earned Premium”, each ﬂ ;
Query Settings X
=z 123 Policy Number Eiiﬁ Entry Date Eiiﬁ Termination Date ﬂlza Plan
" 4 PROPERTIES
2 1 10000001 02/01/2018 02/01/2019
T .S Name
8. 2 10000002 03/01/2018 03/01/2019 )
| Policy Data
3 10000003 04/01/2018 04/01/2019
4 10000004 05/01/2018 05/01/2019
5 10000005 06/01/2018 06/01/2019 4 APPLIED STEPS
6 10000006 07/01/2018 07/01/2019 >
7 10000007 08/01/2018 08/01/2019 - ~N
End_Date
8 10000008 09/01/2018 09/01/2019 Tot Exposure
9 10000009 10/01/2018 10/01/2019 Sou_rce o
10 10000010 11/01/2018 11/01/2019 Poliq.' Data Sheet

. To view connected data file, go to Data tab > Under Queries & Connections section, click Queries &
Connections to display the respective window. Select required query > Right click to select Edit. Excel

will display Query Editor.

. In the Query Editor, you can view the values of the connected data file. However, you are unable to

alter any values like you normally do it Excel.

. Under Query Settings window > Applied Steps section, you can click every step to view actions

applied on the table, after doing all precedent steps.

. It is important to note that Power Query manages steps by fields / columns, instead of individual

|II

“cel
formulas by columns.
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— In Excel, we need to enter formulas into every cell; whereas for Power Query, we are defining
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Data Manipulation I:
Built in Functionalities

. 123 Pelicy Number !ﬁ Entry Date El -3 Termination Date El 123 Plan
1 10000001 02/01/2018 02/01/2019
T 10000002 03/01/2018 03/01/2019
T 10000003 04/01/2018 04/01/2019
T 10000004 05/01/2018 05/01/2019
T 10000005 06/01/2018 06/01/2019
T 10000006 07/01/2018 07/01/2019
7 10000007 08/01/2018 08/01/2019
T 10000008 09/01/2018 09/01/2019
T 10000009 10/01/2018 10/01/2019
T 10000010 11/01/2018 11/01/2019
T 10000011 12/01/2018 12/01/2019
7 10000012 13/01/2018 13/01/2019
? 10000013 14/01/2018 14/01/2019
T 10000014 15/01/2018 15/01/2019
? 10000015 16/01/2018 16/01/2019

4

7. [123 Plan ﬂl.z Count E|1.2 Total Annualized Premium |z||

1 1 10000 8304965.72
T 2 10000 9135577.83
T 3 10000 10049360.67
T 4 10000 11053594.41
T 5 5999 12158244.4
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. Power Query has many user-friendly built-in
functionalities that allow users to perform
data manipulations without needing to
understand M Language.

. Examples of built-in functionalities include
filtering, grouping (such as to count rows and
sum selected fields).

How do we summarize a table?

. Open required query > Go to Home tab >
Under Transform section, click Group by.

. In Group By dialog > Select Advanced > Select
the field which the data should be
summarized by. Click Add Grouping if there
are more than 1 field > Define how the
aggregation to be done. Click Add Aggregation
if you need to summarize more than 1 field >
Click OK.

. To undo the grouping step, go to Applied

Steps > Select the grouping step > Click *
next to the selected step.



Data Manipulation I:
Built in Functionalities (Group By)

STEP 1

@ ¢ - < |Policy Data - Power Query Editor O X
Home Transform Add Column View N o
B ; wy A - 2 - -
P = i/ Properties |_|_|J EEﬁ = [ " Data Type: Whole Number EE.' New Source
= ~ * a
E_ =~ [Jz:‘l‘ Advanced Editor Zl |— —| Use First Row as Headers ~ [(?) Recent Sources ~
Close &  Refresh Manage Reduce Split \ Group J Combine  Manage Data source
- PO = Manage - . 2 Replace Values . . ;
Load Preview Columns ™ Rows Column Parameters settings
Close Query Sort Transform Parameters  Data Sources New Query
X X
Group By Group By
Specify the colymn to group by and the desired output. Specify the columns to group by and one or more outputs.
ic Basic @ Advanced
| Termination Date - | Plan -
New column name Operation Column Add grouping
| Count | | Count Rows v
New column name Operation Column
Cancel | Count | | Count Rows - |
| Total Annualized Premium | | Sum M | | Annualized Premium M
STE P Z Add aggregation
STEP 3
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Data Manipulation I:
Built in Functionalities (Merge)

Merge
Select tables and matching columns to create a merged table.
| Summary (Policy) e (3
Plan Sum Exposure Sum Earned Premium
1 4991.265753 4160616.79
2 4991.736986 4577173.18
3 4992.208219 5035549.57
4 4991.682192 5538247.79
3 4990,.794521 6091201.12
ick matching field
| Summary (Claim) e (&
Plan No of Claim Sum Claim Amount
1 4616 1276788.9
2 89232 2544021.02
3 13846 3862135.77
4 13845 3834534.63
5 18460 5020678.48
ick matching field
Join Kind
| Left Quter (all from first, matching from second) -

|| Use fuzzy matching to perform the merge

I» Fuzzy matching options

+/ The selection matches 5 of 5 rows from the first table.

o] [one

X
STEP 2

Data Type: Whole Number ~ EE.'
+

r[ —h ﬁ Use First Row as Headers ~

Split  Group Combine
Column~ By 2 Replace Values -
Transform
E;'HE Merge Queries b
le.AddColumn(#"Chan—* = W

E'HE Merge Queries

77 Merge Queries as New >

STEP 1

:|| = Table.NestedJoin(#"Summary (Policy)", {"Plan"} ﬂ

E|1.2 Sum Earned Premium El@ Summary (Claim) j
=

1.26 | Search Columns to Expand |
- @ Expand O Aggregate

2.20

169 [m] (Select All Columns)

0. 79 [ Plan

No of Claim Check for required
Sum Claim Amount  fields only

Use original column name as prefix

| oK || Cancel |

STEP 3
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Data Manipulation Il:
Self-defined Calculations

GetValue

(NamedRange)) =>

let
name = Excel.CurrentWorkbook(){[Name=NamedRange]}[Content],
value = name{@}[Columnl]

¥

Advanced Editor

Policy Data

let
Start_Date = DateTime.Date(GetvValue("StartDate")),
End_Date = DateTime.Date(Getvalue("EndDate")),
Tot_Exposure=365,
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. Similar to other programming languages, we can define

variables in the codes that can be used in the subsequent
steps.

. We can assign a constant to a variable or link it to a user-

defined function.

. It is important that data types in Power Query may be

different from Excel. For example, difference between two
dates are considered as Duration Type.

How to make the queries “reusable”?

. Instead of hardcoding the run parameters (e.g. calculation
dates) in coding, we can create a user-defined function to
read values from a worksheet of Excel file. (Please note that
user-defined functions do not need to have “let...in...”
pairings.

. To do so, we need to assign names to the cells that store
run parameters in advance.

. If the run parameters are date values in the worksheet, they
are read as DateTime format by Power Query. To retrieve
the date value, we need to use DateTime.Date function.
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Disclaimer

* The contents of this document are only for the reference of participants
attending ASM Mini Sharing on 09.04.2019. Unauthorized circulation or

duplication of any part of this document to any unauthorized third party is
prohibited.

* The copyrights of this document are owned by ACTBuilder Actuarial
Solutions Sdn. Bhd.

* ACTBuilder Actuarial Solutions Sdn. Bhd is not responsible for
unauthorized use of any part of the contents of this document.

Contact Info:
ACTBuilder Actuarial Solutions Sdn. Bhd. (1108112-P) | Lim Chee Beng | CheeBeng.Lim@actbuilder.com.my
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